股市波段买卖指标源码公式解析(附图)

时间:2021-03-27 08:28:37

在股市交易中,短线操作,波段操作都是实战中的操作策略,那么波段买卖指标具有怎样的源码股票公式呢,我们通过具体的图形源码进行分析,基础公式——买卖指标——波段炒作——波段抄底——轨迹运行。

  1、波段基础主图指标公式

  MA5:MA(CLOSE,5),ColorFFFFFF;

  MA10:MA(CLOSE,10),Linethick2,Color00FFFF;

  MA20:MA(CLOSE,20),Color00FF00;

  MA40:MA(CLOSE,40),ColorFF00FF;

  MA60:MA(CLOSE,60),Color0000FF;

  MA120:MA(CLOSE,120),ColorFFFF00;

  ANGEL:=EMA(CLOSE,2),Color000000;

  DEVIL:=EMA((SLOPE(CLOSE,21))*(20) + CLOSE,42),POINTDOT,Color000000;

  买:=CROSS(ANGEL,DEVIL);

  SEL:=CROSS(DEVIL,ANGEL);

  DRAWTEXT(买,(LOW)*(0.97),'关注'),Color00FFFF;

  DRAWTEXT(SEL,(HIGH)*(1.03),'风险'),ColorFFFFFF;

  STICKLINE((ANGEL >= DEVIL),LOW,HIGH,0.1,0),Color0000FF;

  STICKLINE((ANGEL >= DEVIL),CLOSE,OPEN,4.5,0),Color0000AA;

  STICKLINE((ANGEL >= DEVIL),CLOSE,OPEN,3,0),Color0000CC;

  STICKLINE((ANGEL >= DEVIL),CLOSE,OPEN,2,0),Color0000DD;

  STICKLINE((ANGEL >= DEVIL),CLOSE,OPEN,1,0),Color0000FF;

  STICKLINE((ANGEL < DEVIL),CLOSE,OPEN,1,0),ColorEEEE00;

  STICKLINE((ANGEL < DEVIL),CLOSE,OPEN,2,0),ColorDDDD00;

  STICKLINE((ANGEL < DEVIL),CLOSE,OPEN,3,0),ColorCCCC00;

  STICKLINE((ANGEL < DEVIL),CLOSE,OPEN,4.5,0),ColorAAAA00;

  STICKLINE((ANGEL < DEVIL),LOW,HIGH,0.1,0),ColorFFFF00;

  STICKLINE(CROSS(ANGEL,DEVIL) or CROSS(DEVIL,ANGEL),OPEN,CLOSE,3.5,0),Color00FFFF;

  其中提示了风险的位置和投资者需要关注的点位,将其导入到基本的软件中进行分析,得到如下的图形:

  

 

  2、波段买卖指标

  n1:=5;n2:=10;

  MTM:=C-REF(C,1);

  AA:100*EMA(EMA(MTM,n1),n1)/EMA(EMA(ABS(MTM),n1),n1),colorwhite,LINETHICK3;

  MAAA:MA(AA,N2),coloryellow,LINETHICK3;

  STICKLINE(AA>MAAA,AA,MAAA,1,0),colorffffff;

  v0:0,colorffa2af;

  显示和描述的是股价在一个波段中的买点和卖点的位置,其基本图形如下:

  

 

  3、波段炒作指标公式

  卖出线: 99;

  阶段卖: 90;

  趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2;

  底部: 10;

  买入警戒: IF(趋势<=10,50,0);

  买入信号: IF(CROSS(趋势,底部),100,0);

  卖出警戒: IF(趋势>=90,50,100);

  为投资者指出了波段技巧中进行操作的卖出线和买入信号,希望投资者能够把握其中的操作机会,具体的请研究图中的走势变化:

  

 

  4、波段抄底指标公式

  HLM1:=MA(HHV(H,485),17);

  HLM2:=MA(HHV(H,222),17);

  HLM3:=MA(HHV(H,96),17);

  HLM4:=MA(LLV(L,485),17);

  HLM5:=MA(LLV(L,222),17);

  HLM6:=MA(LLV(L,96),17);

  HLM7:=MA((HLM1*0.558+HLM2*0.558+HLM3*0.558+HLM4*0.96+HLM5*0.96+HLM6*0.96)/6,17);

  HLM8:=MA((HLM1*0.55+HLM2*0.55+HLM3*0.65+HLM4*1.25+HLM5*1.23+HLM6*1.2)/6,17);

  HLM9:=MA((HLM1*0.68+HLM2*0.68+HLM3*0.68+HLM4*1.3+HLM5*1.3+HLM6*1.3)/6,17);

  HLM10:=MA((HLM7*3+HLM8*2+HLM9)/6*1.738,17);

  HLM11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;

  HLM12:=MA(IF(C*1.35<=HLM10,HLM11*10,HLM11/10),3);

  HLMH:=HHV(HLM12,30);

  关注:MA(IF(L<=LLV(L,13),(HLMH+HLM11*2)/2,0),3)/200,COLORFFFFFF;

  DRAWTEXT(CROSS(关注,1.2),关注*0.5-6,'↑▲'),COLORFF00FF;

  DRAWTEXT(CROSS(关注,4.5),关注,'买点出现'),COLOR00FFFF;

  DRAWICON(CROSS(关注,7.0),关注*0.5-20,14);

  关注的是股价阶段性底部的走势变化,寻找合适的抄底机会,其走势图形如下:

  

 

  5、波段轨迹公式

  CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;

  主力线:(EMA(CS,3)-50)*2;

  极弱:-80;

  强势:60;

  风险:80;

  弱势:-60;

  主力线,COLORSTICK;

  今日保护价:(REF(C,1)+REF(C,2)+O)/3,linethick0;

  VAR1:=REF(CLOSE,1);

  VAR2:=SMA(MAX(CLOSE-VAR1,0),6,1)/SMA(ABS(CLOSE-VAR1),6,1)*100;

  STICKLINE(CROSS(75.9,VAR2),主力线+5,主力线-5,3,0),coloryellow;

  DRAWTEXT(CROSS(主力线,78),78,'清仓'),colorred;

  DRAWTEXT(CROSS(主力线,强势),60,'飙升'),coloryellow;

  DRAWTEXT(CROSS(主力线,0),0,'控盘'),colorwhite;

  DRAWTEXT(CROSS(主力线,-60),-30,'回补'),colorgreen;

  DRAWTEXT(CROSS(主力线,-80),-80,'吸筹'),colorcyan;

  在轨迹公式中,讲解了主力线,强势区域与弱势区域的范围,和相应的控盘、吸筹、回补等操作,具体的走势形态如下:

  

  以上就是本文讲解的关于波段操作的相关指标源码公式的汇集,如果您想要了解更多的股市操作源码公式,请关注股票学习网,为您讲解更加详细的指标公式!

文章推荐:

国产软件概念股有哪些 国产软件概念题材股票

短线炒股有哪些分时形态?

医药股票还能投资吗

如何判断买卖股票的最佳时机

炒股能在几家证券开户

炒股怎么网上开户?股票开户的三种形式

最看好的十支股票

股票增发是利好还是利空

邮票投资与股票投资有何不同

选股的基本思路有哪些?

股票交易中的人性

股票短线操作技巧大全-资深玩家分享

申购新股中签技巧?股票打新是什么?

怎样买创业板股票?炒股怎么买创业板?

新手怎样选股票?如何选择好的个股?