八字kdj股票技术指标公式源码(图解)

时间:2021-04-26 08:27:38

在技术指标的应用操作中,我们知道的是kdj指标是一种随机指标,用来判断个股的买卖点以及个股趋势的偏离程度,但是八字kdj指标公式是怎样的,你知道吗?其实,在股市中的应用也离不了指标本身的操作原理和实战意义,下面我们就其基本的公式源码进行图解分析。

  首先与基本的kdj指标类似,有K/d/j三条指标线的走势变化,还有一种尖角指示的指标线在个股的走势过程中,标注出指标线提示的买卖点位置,具体的源码如下:

  D:= EMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,20);

  J:= EMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5);

  BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

  BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

  BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

  八字KDJ4:EMA(D,3),COLOR00FF00,LINETHICK2;

  M:EMA(J,7),COLORWHITE,LINETHICK2;

  八字KDJ: ((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)

  -2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)

  -50)*1.032+50),COLORRED,LINETHICK2;

  买线:=EMA(C,2);

  卖线:=EMA(SLOPE(C,21)*20+C,42);

  STICKLINE(买线>=卖线,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),

  COLORWHITE;

  STICKLINE(买线<卖线,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),

  COLORYELLOW;

  VAR1:=1;

  VAR2:=(2*CLOSE+HIGH+LOW+OPEN)/5;

  VAR3:=LLV(LOW,34);

  VAR4:=HHV(HIGH,34);

  RR:=EMA(EMA(CLOSE,9),9);

  控盘:=(RR-REF(RR,1))/REF(RR,1)*1000;

  A10:=CROSS(控盘,0);

  买两股:IF(A10,50,0),LINETHICK1,COLORYELLOW;

  AR1:=PEAKBARS(3,15,1)<10;

  AR2:=IF(AR1=1,2,0);

  顶:= IF(AR2=2,2,0);

  卖出好:IF(顶>REF(顶,1),50,0),COLORWHITE;

  DRAWTEXT(卖出好=45,50,'快走'),COLORRED;

  买: (ZIG(3,35)>REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)

  *50,STICK,COLORMAGENTA,LINETHICK3;

  卖: (ZIG(3,35)REF(ZIG(3,35),2))

  *50,STICK,COLORLIBLUE,LINETHICK3;

  VAR21:=MA(CLOSE,80)-(MA(CLOSE,13))/(3);

  VAR22:=MA((CLOSE-VAR21)/(VAR21),1);

  VAR23:=(EMA(VAR22,12))*(0.69999998);

  VAR24:=EMA(VAR22,3);

  VAR25:=IF((LLV(VAR24-VAR23,12)>0),0,(-30));

  VAR26:=FILTER((COUNT((VAR25<(-20)),3)=3),34);

  快全买:IF(VAR26,50,0),COLORLICYAN;

  顶线:100,COLORRED;

  底线:0,COLORGREEN;

  其次,从八字kdj指标的源码公式中能够看出,指标公式中提示出了个股走势中的买线和卖线位置以及买卖之间的主力控盘程度的分析,当然也可以通过指标的走势,判断出个股的顶部和底部的形态,进而做好卖出和买入的基本操作。

  以上就是本文对八字kdj指标的买卖技巧以及基本的源码公式的简单介绍,如果您还想要了解更加专业的技术指标分析技巧,或者是想要了解更加全面的技术指标源码公式,请百度输入股票技术指标公式,寻找股票学习网的标识,点击学习!

文章推荐:

电子商务概念、最新电子商务概念股龙头一览

新手短线选股:选股看什么

股票做短线的技巧

股票中的盘口是什么意思

刚上市的新股跌破发行价意味什么?

买股票我们该选择大公司吗?

投资理财哪个平台好 最安全的理财投资平台

短线股票交易需要掌握哪些技巧?短线股票操作技巧

炒股技巧有哪些?炒股需要具备哪些条件

开户炒股应该如何选择证券机构?

股市波段买卖指标源码公式解析(附图)

国产软件概念股有哪些 国产软件概念题材股票

短线炒股有哪些分时形态?

医药股票还能投资吗

如何判断买卖股票的最佳时机